aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..9afd3f6
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,34 @@
+{
+ description = "Example Go development environment for Zero to Nix";
+
+ inputs = {
+ #nixpkgs.url = "https://flakehub.com/f/NixOS/nixpkgs/0.2305.491812.tar.gz";
+ };
+
+ # Flake outputs
+ outputs = { self, nixpkgs }:
+ let
+ allSystems = [
+ "x86_64-linux" # 64-bit Intel/AMD Linux
+ "aarch64-linux" # 64-bit ARM Linux
+ "x86_64-darwin" # 64-bit Intel macOS
+ "aarch64-darwin" # 64-bit ARM macOS
+ ];
+
+ forAllSystems = f: nixpkgs.lib.genAttrs allSystems (system: f {
+ pkgs = import nixpkgs { inherit system; };
+ });
+ in
+ {
+ devShells = forAllSystems ({ pkgs }: {
+ default = pkgs.mkShell {
+ packages = with pkgs; [
+ zig
+ hugo
+ rsync
+ postgresql
+ ];
+ };
+ });
+ };
+}